SAP Knowledge Base Article - Public

2167624 - Mean Score Displays as N/A or -1 on the Survey Report

Symptom

The Surveys Report, which pulls data for the Course Feedback Survey, shows a Mean Score = N/A or -1

Environment

SAP SuccessFactors Learning

Reproducing the Issue

  1. Assign a Course Feedback Survey to an Item.
  2. Complete the Item and Survey as a user.
  3. Go to Content > Surveys > Access the Survey record > Item Usage
  4. Note that the Mean score = N/A.

Cause

A mean score cannot be calculated when more than one rating scale is used within a survey. This is stated on the Surveys report description tooltip.

In case you see that the Rating Scales are all the same, but still the Mean Score is not calculating, there's a possibility that the Survey was created with different Rating Scales and users completed this Survey version. An admin then edits the Survey questions, remove the different ones, include them back with the correct Scale and now them all meet.

Due to the fact that users completed the old survey version, Learning no longer calculates the Mean Score because of the old survey answers.

Resolution

Create a copy of the related survey and set only one rating scale for the new survey.

Note: Please test in a stage environment before making changes to the Survey/Item relationship. A new revision of the Item with the new Survey might be ideal for keeping track of the different responses and data.

See Also

Copying a Survey as a Template for New Surveys

Keywords

not, working, report, survey, questionnaire, evaluation, item, evaluation, by, instructor, na, course, mean, score, value , KBA , LOD-SF-LMS-REP , Reporting Data , LOD-SF-LMS , Learning Management System , LOD-SF-LMS-EVA , Surveys , Problem

Product

SAP SuccessFactors Learning all versions