SAP Knowledge Base Article - Public

2168823 - How to analyze Boomi error : "Found more than 1 document in the document cache"

Symptom

  • How to analyze Duplicate record in Document cache:

Example:

Error Message:- [Function: jobReqID_to_packageName_packageId, Document Cache Lookup (Step 2)]: Found more than 1 document in the document cache (index: enUS, keys: []); Caused by: Found more than 1 document in the document cache (index: enUS, keys: []) Error Log:- com.boomi.store.DataStoreException: Found more than 1 document in the document cache (index: enUS, keys: [])

Environment

Boomi

Cause

When  boomi process execution fethces records from document cache and found more than one document ID with same unique identifier, it fails with above error message.

Resolution

  • Add a branch before the Add to Cache step(s) in the interface.  Move the Add to Cache shape to the second branch and on the first branch add a Disk or FTP connector to write the same data to disk.
  • Deploy the process with these changes.  Then you can view the data on the Disk or FTP connector in Process Reporting to see what was populated in the Document Cache for analysis. 

Keywords

KBA , LOD-SF-INT , Integrations , Problem

Product

SAP SuccessFactors HCM Suite all versions