SAP Knowledge Base Article - Public

2174179 - Ad Hoc Report Error when reporting on Employee Profile Attachments – org.eclipse.birt.report.service.api.ReportServiceException

Symptom

Customers can face an exception error when reporting on attachments that were uploaded in Employee Profile. This article explain the cause and the resolution for the same.

Environment

SAP SuccessFactors HCM CORE

Reproducing the Issue

Error:

Error.png

Cause

In instance data model (XML), when using the "Define employee fields" tool, the document-type-id is not set to correct value and is set to UNSPECIFIED. Then Ad Hoc can not report on document type UNSPECIFIED

Example:

<data-field id="attachment" field-name="attachment1" max-length="999" document-type-id="UNSPECIFIED" max-file-size-KB="5000" file-formats="doc|docx|pdf|ppt|pptx">

Resolution

Please log a ticket to support or ask your Implementation Partner to change document-type-id to "ATTACHMENTS", or other values on he data model.

Example:

<data-field id="attachment" field-name="attachment1" max-length="999" document-type-id="ATTACHMENTS" max-file-size-KB="5000" file-formats="doc|docx|pdf|ppt|pptx">

Customers need to fill out CCOR and proceed with the required process for XML code changes.

Keywords

org.eclipse ReportServiceException, Employee Profile Ad Hoc Report, Ad Hoc Report Attachments , KBA , LOD-SF-EP-REP , Ad Hoc Report (Employee Profile) , Problem

Product

SAP SuccessFactors HCM Core 1705