Symptom
-
Crystal Reports crash.
- When attempting to logon to Salesforce.com, and selecting the option "Use Analytic API", Crystal Reports 2013 terminates unexpectedly.
- Note: Images and data in this SAP Knowledge Base Article is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental.
Environment
- SAP Crystal Reports 2013 - Support Pack 05, Patch 4 and above.
- Salesforce.com
Reproducing the Issue
- In Crystal Reports 2013 create a new report.
- In the "Database Expert" window, expand "Create New Connection", and double click on "Salesforce.com"
- In the "Salesforce.com" logon window, enter the credentials for a Salesforce.com account.
- Check the option "Use Analytic API"
- Click "Finish", and notice Crystal Reports 2013 will terminate unexpectedly.
Cause
- This issue occurs when the Salesforce.com account contains more than 4,000 Salesforce.com reports.
- If the Salesforce.com has a smaller number of Salesforce.com reports, like 2,000, it connects successfully to Salesforce.com from Crystal Reports.
- This issue has been reproduced at SAP, and has been tracked under SAP Note 2174325
Resolution
- There is unfortunately no product update that resolves this issue at this point.
Keywords
CR, sforce. SForce, crash , KBA , BI-RA-CR , Crystal Reports designer or Business View Manager , Bug Filed
Product
SAP Crystal Reports 2013