Symptom
When using the "Download Search Results" function in any of the search wizards in Learning admin.
- For example, in the user search, perform a blank search and click the "Download Search Results" option:
-
In the downloaded excel file, you only see the same amount of records every time, even though there is a higher number of total records in the database, which can be checked via a standard report or in the search results screen, as per below:
Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental.
Environment
SAP SuccessFactors Learning
Reproducing the Issue
As an example, you can use the search wizard in users:
- Learning admin > People > Users >
- Perform a blank search >
- Click "Download Search Results" >
- Open the excel file and observe the number of records available in the file.
Cause
The reason why this function always returns the same number of records is due to the value set in the "resultMaxRowAllowed" parameter. The search will return the exact value of records seen in that setting.
This will happen even if there are more records in the database.
Resolution
- Learning admin > System Administration > Configuration > System Configuration >
- Edit the "SEARCH" configuration >
- At the very start of this config file, you will see the "resultMaxRowAllowed" parameter. Change this to a value that fits the business needs >
- Save the new value by clicking "Apply Changes" >
- Run the search again and download the results. You will find that, it will return the value that you set for this parameter.
See Also
Keywords
LMS, resultMaxRowAllowed, Download Search Results, download, search, result, does, not, show, all, records, excel, limited, truncated, truncate , KBA , LOD-SF-LMS-REP , Reporting Data , LOD-SF-LMS , Learning Management System , LOD-SF-LMS-ADM , System Admin, Global Variables, References , Problem