Symptom
- When using the "Download Search results" function in any of the search wizards in LMS Admin. For example, in User Search:
-
In the downloaded excel file, you only see the same amount of records every time even though there are a higher number of total records in the database
Environment
SAP SuccessFactors Learning Management System (LMS) - All Supported Versions
Reproducing the Issue
As an example, you can use the search wizard in Users
- In the LMS Admin, Open Users.
- Perform a blank Search
- Click "Download Search Results"
- Open the Excel file downloaded and observe the number of records downloaded to the file.
Cause
The reason why this function always only returns the same number of records is due to the value set for the Parameter "resultMaxRowAllowed". Whatever this value is set to, a search will only ever return that value even if there are more records in the database.
Resolution
- Go to System Admin
- Configuration
- System Configuration
- Edit the Configuration "SEARCH"
- At the very start of this config file, you will see the parameter "resultMaxRowAllowed". Change this to another value.
- Save the new value by clicking on Apply Changes.
- Run the search again and download the results. You will find that, it will return the value that you set for this parameter.
See Also
Keywords
LMS, resultMaxRowAllowed, Download Search Results, Downloading Search results does not show all records, excel, Microsoft Excel, , KBA , LOD-SF-LMS-COR , LMS Core - Items, Catalog, Curricula , LOD-SF-LMS , Learning Management System , LOD-SF-LMS-ADM , System Admin, Global Variables, References , Problem