Symptom
- Error: "Failed to open the connection."
- Was able to login to Salesforce.com from Crystal Reports in the past, but it now generates an error.
- When attempting to logon to Salesforce.com from Crystal Reports, it fails to open the connection and display the error:
"Failed to open the connection."
"Details: Unexpected error"
"The users password has expired, you must call SetPassword before attempting any other API operations"
- Note: Images and data in this SAP Knowledge Base Article is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental.
Environment
- SAP Crystal Reports 2008
- SAP Crystal Reports 2011
Reproducing the Issue
- In Crystal Reports, create a new report, and select the data source: "Salesforce.com"
- Enter the Salesforce.com user name and password, and click "Finish"
Crystal Reports fails to open the connection and display the error:
"Failed to open the connection."
"Details: Unexpected error"
"The users password has expired, you must call SetPassword before attempting any other API operations"
Cause
- Crystal Reports fails to login to Salesforce.com because the user's password needs to be reset due to Salesforce.com security policy set for the user to change the password at a regular interval.
Resolution
-
To successfully logon to Salesforce.com from Crystal Reports, login to Salesforce.com website, and change your password as required by Salesforce.com security policy:
- In a web browser, enter the Salesforce.com url: https://login.salesforce.com/
- Enter the Salesforce.com user name and password. and click "Log in to Salesforce"
- In the "Change Password" screen, enter a new password, and click "Save"
- It will now be possible to successfully connect to Salesforce.com from Crystal Reports with the new password.
Keywords
CR, Sforce , KBA , BI-RA-CR , Crystal Reports designer or Business View Manager , Problem
Product
Crystal Reports 2008 V1 ; SAP Crystal Reports 2011