Symptom
Purge request is not shown on "Requests Awaiting Approval" tab, but instead appear directly on "Approved Request" tab with status "failed". As screenshot below:
Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental.
Environment
- SAP SuccessFactors HXM Suite
- SAP SuccessFactors Learning Management System (LMS)
Reproducing the Issue
- Create a user purge request;
- Go to Purge Request Monitor;
- The request just created will not be shown on "Requests Awaiting Approval" tab;
- Go to "Approved Request" tab;
- You will see the purge request with status failed.
- If you click the approved below the "Failed" high lighted, you will see as if the purge is on reviewing by the approvers:
Cause
- Learning Management System (LMS) is enabled from Provisioning > Company Settings but no LMS URL is configured (misconfiguration)
- User submitting purge does not have Learning Management System (LMS) admin permissions.
- Learning Management System (LMS) is enabled from Provisioning > Company Settings but LMS is decommissioned
Resolution
Resolution for cause #1:
- Ensure that Bizx - LMS integration is properly configured.
- In some cases, LMS setting is enabled in Provisioning > Company Settings Page while no LMS URL is configured.
- This will result to the purge to automatically fail after approved by the admin user. Please refer to KBA 2318325 for further details on BizX to LMS integration.
Resolution for cause #2:
- If the Learning Management System (LMS) integration is enabled, as suggested in KBA 2088065, the bizX user submitting the purge should satisfy the following conditions. Otherwise, the purge submitted will automatically fail without approval.
- User creating purge request must a have matching user in LMS (same ID as the userID in bizx) so Bizx ID=LMS user ID= LMS admin ID
- The LMS admin must have the following workflows in the LMS role assigned to them: "View User", "Delete User"
Note: How to make an Admin user on LMS?
To make an Admin user on LMS you can follow the steps below:
- Create an Admin User in LMS with same UserID/Username as the admin used in BizX to run the purge (approver) as referred on this KBA 2103344;
- Grant full permission to all Domains and permission to delete users;
- Make sure that the LMS admin has an LMS user tied to it. This user must to have the same UserID/Username as illustrated below:
- On BizX, make sure that the user has Learning Admin permission on RBP (as referred on KBA 2489829);
- Also, check that the UserID being purged in BizX/EC has a valid LMS User (if not create the user and run the purge again).
Resolution for cause #3:
- If you are experiencing the Purge automatic failure with status set as "reviewing" and LMS was decommissioned in your environment
- you may be experiencing cause #3: on Provisioning > Company Settings > the Learning Management System (LMS) is enabled
- An SAP partner or SAP support can access provisioning and disable it.
Keywords
Data Management, Purge user, failure, LMS, sf, sf, sfsf , sf sf, SuccessFactors, SuccessFactor, Success, Factor , bizx, plt, failed, purge reviewing, Exception is caught when getting person type by user ids, Splunk, server logs, job failed, 2005, release, issues, new error, error message is The user is not permitted to perform the requested operation, INC0074434, DRMAccessException, EAS-16067 , KBA , LOD-SF-PLT-DRM , Data Retention Management , LOD-SF-PLT , Platform Foundational Capabilities , Problem