SAP Knowledge Base Article - Public

2180909 - For how long are the SFAPI Audit logs available?

Symptom

  • Logs in SFAPI Audit logs are not available
  • When attempted to download audit logs, the below error is seen:

    Failed to get the message details: message content has been deleted

    purged logs.jpg

 

Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental.

Environment

SAP SuccessFactors

Reproducing the Issue

Navigate to Admin Tools - SFAPI Data Dictionary - Click on the icon below "SOAP" (Screenshot attached below)

 

audi222.jpg

 

 

Cause

If the Audit log which is being downloaded/viewed is older than the 10,000th log, the message of the log would be purged

Resolution

This is system behavior.

The Audit log setting is defaulted to 10,000 in the backend ie., Maximum message body count is 10,000 and Maximum log count is 1,000,000.

See Also

Frequently asked questions:

1) Can the setting be enhanced so as to store more logs? - No

2) Can operations or other SAP teams help in retrieving lost logs? - No

Keywords

SF SuccessFactors maintain long length of time kept keep Audit logs purged sfapi audit logs api INT , KBA , LOD-SF-INT-API , API & Adhoc API Framework , LOD-SF-INT , Integrations , How To

Product

SAP SuccessFactors HCM suite all versions