Symptom
You have added an embedded report to a UI. When trying to set up a mapping between the parameter and the screen field, you notice that the dropdown list for the screen field is not offering the field you are looking for.
Environment
SAP Cloud for Customer
Reproducing the Issue
Let us assume you have added the report All Tickets to the ticket overview. For this case,
- Go to the work center Services, view Tickets.
- Open a ticket and enter the adaptation mode.
- Scroll down to the embedded report All Tickets and click Edit.
- For the respective parameter, click the dropdown list for the column Screen Field.
Here you notice that the field you are looking for is missing.
Cause
A) Currently, only fields of type List (Code Value List), Identifier, Indicator, Datetime and Date are supported for mapping. The field you are looking for is of another type, for example Name (that is, text).
B) Another cause might be that your field is not yet part of the header section of that screen. For a field to be mapped as a screen field in an embedded report, this field should be moved to the header section.
Resolution
A) Only fields of type List, Identifier, Indicator, Datetime and Date can be mapped. Please note, that a field of type Identifier cannot be created in the adaptation mode. If you need the type Identifier, you can use the SAP Cloud Studio Application to create this extension field.
B) Go to the Adaptation mode and drag and drop your field from its current section to the header.
Keywords
embedded report, screen field, mapping, text field, report adaptation mode, missing field, header, ticket , KBA , extension field , AP-RC-ANA , C4C, ByD, Travel: Analytics Tools & Frameworks , How To