Symptom
When adding a new employee to SuccessFactors, the workflow that is triggered has one or more of these issues:
- The approvers attached to the workflow shows the role or dynamic group name rather than the named user.
- Approvers are missing from the workflow
Environment
SuccessFactors Employee Central
Reproducing the Issue
- Hire a new employee from Admin Tools > Add New Employee
- Fill in the required fields and Save to initiate the workflow
- Expand the list of approvers on the workflow and check if the correct approvers are shown
You can verify the expected approvers by checking the workflow configuration in Admin Tools > Manage Organization, Pay, and Job Structures.
Cause
One or more approver step in the Workflow Configuration has the attribute Context set to Source. Source is not a valid selection in this scenario, because the employee is new and thus does not yet have any job relationships with other employees.
Resolution
- Access Admin Tools
- Click on Manage Organization, Pay and Job Structures
- In Search, select Workflow Configuration in the first drop down
- Select the new hire workflow that is being initiated when hiring the employee
- Select Take Action > Make Correction
- Change all approver steps with Context: Source to Target
- Save
Keywords
incorrect, range penetration, pay range, approved, rehire, bizx , KBA , LOD-SF-EC-WFL-TOL , Admin Tools, Pending Req, Admin Alerts, Check Tool , LOD-SF-EC-HIR-NEW , Add New Employee Wizard , Problem