SAP Knowledge Base Article - Public

2188766 - Lumira Desktop Stuck at Start Engine Stage

Symptom

When launching Lumira Desktop, the splash screen is stuck at "Start Engine" stage.

In Lumira Desktop trace log, the following errors are recorded:

2015/07/03 09:24:33.030000|>>|S| | 1424|   1| |||||||||||||||[com.sap.hilo.desktop.embeddedserver.ContentProviderFactory]Failed add content from Content Provider : class com.sap.hilo.desktop.share.v2.boe.ContentProvider
java.lang.RuntimeException: Error while writing new license to disk.
 at com.sap.hilo.capabilities.keycode.KeycodesManager.writeToDisk(KeycodesManager.java:499)
 at com.sap.hilo.capabilities.keycode.KeycodesManager.<init>(KeycodesManager.java:63)
 at com.sap.hilo.capabilities.keycode.KeycodesManager.createFromDisk(KeycodesManager.java:72)
 ...
Caused by: java.io.FileNotFoundException: C:\Users\Public\sapvi\hilo_license.properties (Access is denied)
 at java.io.RandomAccessFile.open(Native Method)
 at java.io.RandomAccessFile.<init>(RandomAccessFile.java:241)
 at com.sap.hilo.capabilities.keycode.KeycodesManager.writeToDisk(KeycodesManager.java:495)
 ... 27 more

Environment

  • SAP Lumira Desktop (any version)
  • Sap Lumira Discovery 2.x

Reproducing the Issue

  1. Launch Lumira Desktop
  2. Startup process is stuck

Cause

Lumira Desktop process is unable to write to the default shared folder "C:\Users\Public\sapvi"

Resolution

Please make sure the Windows user you are using have sufficient read and write access to the default shared folder "C:\Users\Public\sapvi" (SAPVI_2 folder for Lumira Discovery) by:

  1. Log in as the windows administrator

  2. Navigate to the public .sapvi2 or .sapvi folder which is located:
    <ROOT_DRIVE>:\Users\Public\sapvi_2

  3. Right click on this folder and click on properties

  4. Click on the "Security" tab

  5. Find the group/user name of the non-admin user account and click on the "Edit" button

  6. Ensure the non-admin user/user group is selected from the "Group or user names:" list

  7. Check the "Allow" box on all of the permissions for this folder

  8. Click on the "OK" button

  9. Navigate to the users .sapvi2 or.sapvi folder which is located:
    <ROOT_DRIVE>:\Users\<non-admin user>\.sapvi_2

  10. Perform steps 3-8 on this folder

OR

You can change the shared folder location setting by:

  1. Go to Lumira Desktop installation directory, default is "C:\Program Files\SAP Lumira\Desktop"
  2. Open the file "SAPLumira.ini" in a text editor (e.g. notepad). If you are not logged in to Windows as the local administrator, you will need to run the text editor as administrator first, then open this file.
  3. Append the following parameter to the "SAPLumira.ini" file:
    • -Dhilo.shared.dir=<path> (The <path> should be pointing to a folder that your user account has read and write access to, for example, "-Dhilo.shared.dir=C:\LumiraShared")
  4. Save and close the file
  5. In the default shared folder, you should see these files. Copy all of them to your new shared folder.
    • cs_drivers.xml (may not exist if you haven't configured JDBC driver)
    • hilo_license.properties
    • sapvi_info.properties
  6. Now, you should be able to launch Lumira Desktop once again, and it will be using the new shared folder.

Note: There is another parameter that comes with "SAPLumira.ini" by default, -Dhilo.shared.dir.name=sapvi. This specifies the name of the shared folder. It can be changed if needed,

Keywords

cannot, can't, can not, open, start, initiate, run, execute, lum, dsk, startengine, java, not working, issue, problem, error, win 7, win 8, 32 bit, 64 bit, directory, folder, , KBA , BI-LUM-DIS , Lumira Desktop/Discovery , How To

Product

SAP Lumira, desktop edition 1.0