Symptom
1. Cost Centre is associated to multiple Legal Entities. Where LE-1(01) and LE-2(11) are two legal entities associated to Cost Centre.
2. When an upsert call is made to a SFAPI entity FO_costCenter, the existing Legal Entities are wiped off and the Legal Entity LE-3(63) which is sent in the SFAPI call is upserted successfully.
Environment
Successfactors Employee Central
Cause
- Logon to successfactors system,
- Go to admin tools-> Integration tool->SFAPI audit logs
- Check the corresponding SOAP Request.
- We can see from the below log that, only one Legal Entity is being sent in the request and the parameter used is incremental purge:
This is the Root Cause for the issue.
Resolution
This is expected product behaviour.
To Upsert the new value without wiping off the current Legal Entities, the request should be sent in the following format.
Provide 3 value for the field with '|' as the separator.
For Example:
'01|11|63' should be the correct value.
CostCenter Upserted Successfully.
Keywords
KBA , LOD-SF-INT-EC , Employee Central SFAPI & OData Entities , Problem