SAP Knowledge Base Article - Public

2190753 - No Hyphen Allowed in Address Panel

Symptom

  • Physical Address Panel in NES is standard panel and we should be able to enter "–" in the address field.
  • Unable to enter "–" in the physical address panel during NES step.

- Address 1 – illegal symbols have been entered.

Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental

Environment

  • SAP SuccessFactors HCM Suite
  • SAP SuccessFactors Onboarding

Reproducing the Issue

  1. Log in to the SF HCM instance with appropriate credentials:

 11.png

     2. Go to onboarding and open settings > Panels > New Employee Step > US_I9_Physical Address Panel and add any address using a "–" (hyphen)

1.png

Cause

  • This error is due to misconfiguration of XpressHR.Wizard.ValidatorRegEx.Address key in Super Admin site > Account Options.
  • The Key XpressHR.Wizard.ValidatorRegEx.Address is not setup in the Super Admin site > Account Options

Resolution

  1. Log in to the Super Admin site:

 2.png

     2. Go to the instance > Account options and Search for XpressHR.Wizard.ValidatorRegEx.Address in the search box:

 4.png

     3. If unable to find any Key, add a new key with below details:

                      Key: XpressHR.Wizard.ValidatorRegEx.Address

                      Value: [^{\.,?!\'\" + '"' + @";:\(\)\-_}]+

Note: Remove "–" from the above value and click on create button.

 5.png

  1. Now, if replication steps are followed, the validation error message will not be received.

Keywords

SF, Success Factors, ONB, OBD, Special Characters , KBA , LOD-SF-OBD , Onboarding , Problem

Product

SAP SuccessFactors Onboarding all versions