Symptom
Boomi Packaged Integration Interface "EC Payroll (AddOn) to EC - Employee Confirmation v5.0" fails with the following error:
"Error decrypting password.; Caused by: Decryption error"
Environment
Boomi Platform
Cause
Connection settings are not maintained in Boomi Environment Extensions for this Packaged Integration:
Here, you can see that "Use Default" option has been disabled but corresponding data has not been maintained.
Password information has been maintained but there is no username or Company ID maintined:
Resolution
Maintain the connection settings as highlighted in the screenshot above.
Keywords
Employee Confirmation v5.0, Error decrypting password, Decryption error , KBA , LOD-SF-INT-BOM , Standard SF to 3rd Party Boomi Content , Problem