Symptom
If users have Learning Items with "Completed" status in LMS and the correspondent Learning Activity with “Planned” status in CDP, how can I correct the status of the affected Learning Activities in CDP so they are the same as in LMS?
IMPORTANT: As mentioned below we would like to mention again that all items mentioned at the bottom of the KBA must be provided when creating the ticket with support.
Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental.
Environment
- SAP SuccessFactors Career Development Planning
- SAP SuccessFactors Learning Management System
Cause
When a Learning Activity is completed in LMS, the status of this Learning Activity is also updated in the Career Development Plan. If this synchronization fails for any reason, Cloud Product Support needs to be engaged to correct the status of the Learning Activities via script.
Note: Learning Activities should not be launched/completed while proxying.
Resolution
To correct inconsistencies between the status of Learning Activities in CDP and LMS, a script needs to be executed to set the Learning Activity status in CDP to "Completed".
Collecting required data
If you identify any inconsistencies of this kind, create a case in the Support Portal referencing this KBA, and include a list of the Learning Activities that need to be updated and their IDs, name, completed date and assigned userID.
IMPORTANT: The process for correcting the status of Learning Activities cannot be reverted, so caution is advised to be absolutely sure that the Learning Activities provided in the list are the correct ones.
To generate the list of Learning Activities and the required information:
- Go to Ad Hoc Reports;
- Create a new report with the “Development Goal/Objective” domain;
- Under columns, select the fields corresponding to the Learning Activity ID, Learning Activity Name, Completed Date, and Employee (assigned user) which can be found in the Learning Activity section of the columns:
NOTE: The specific name of this field may change depending on the wording you have defined in your instance for Learning Activities (for example: Learning Action ID, Learning Opportunity ID, etc.)
To generate the list of "last updated user” and "origin":
NOTE: only Learning Administrator can retrive this data.
- Go to Learning Administration
- Access the Reports section
- Search for the User Learning Plan Audit Report
- Access the report and filter based off the User and Item
- Schedule Job
- Download the report after completion
- Check the Action column for Insert to know when the item was first added to the Learning Plan while cross referencing the Origin Column to validate that it was added via CDP
Reporting the issue to Technical Support
Once both reports are ready, Technical Support can proceed with the script to correct the status of the Learning Activity in CDP.
We will need your written approval and confirmation to run the script understanding that this change cannot be reversed.
Please refer to our Best Practices KBA for opening cases with Technical Support and reference this article when creating the case in our Portal.
All of the following are needed for support to proceed with creating the request for the script request to be completed:
- The export files of the reports mention above
- Wrriten approval to run the script understanding that this change cannot be reversed
Keywords
SuccessFactors, Learning, CDP, LMS, career development plan, learning activity, status, planned, completed, synchronization, LMS, activities , KBA , LOD-SF-CDP-LA , Learning Activity Plan (LMS) , LOD-SF-LMS , Learning Management System , LOD-SF-LMS-CDP , Career Development Program , Known Error