Symptom
If users have Learning Items with "Completed" status in LMS and the correspondent Learning Activity with “Planned” status in CDP, how can I correct the status of the affected Learning Activities in CDP so they are the same as in LMS?
IMPORTANT: As mentioned below we would like to mention again that all items mentioned at the bottom of the KBA must be provided when creating the ticket with support.
Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental.
Environment
- SAP SuccessFactors Career Development Planning
- SAP SuccessFactors Learning Management System
Cause
When a Learning Activity is completed in LMS, the status of this Learning Activity is also updated in the Career Development Plan. If this synchronization fails for any reason, Cloud Product Support needs to be engaged to correct the status of the Learning Activities via script.
Note 1: Users/Admins must complete the Learning Activity by accessing LMS via BizX login. If the users/admins access LMS using native LMS login, this synchronization will not be triggered.
Note 2: Cloud Product Support will only proceed with the process of updating the Learning Activity status when the Learning Activity was completed via BizX, and not via native LMS login, as native LMS login is not supported.
Note 3: Learning Activities should not be launched/completed while proxying.
Resolution
To correct inconsistencies between the status of Learning Activities in CDP and LMS, a script needs to be executed to set the Learning Activity status in CDP to "Completed".
If you identify any inconsistencies of this kind, create an case in the Support Portal referencing this KBA, and include a list of the Learning Activities that need to be updated and their IDs,
IMPORTANT: The process for correcting the status of Learning Activities cannot be reverted, so caution is advised to be absolutely sure that the Learning Activities provided in the list are the correct ones.
To generate the list of Learning Activities and their IDs:
- Go to Ad Hoc Reports;
- Create a new report with the “Development Goal/Objective” domain;
- Under columns, what is required for Support to correct the Learning Activities is the “Learning Activity ID” which can be found in the Learning Activity section of the columns:
The specific name of this field may change depending on the wording you have defined in your instance for Learning Activities (for example: Learning Action ID, Learning Opportunity ID, etc.)
- See below a sample of how this report would look like:
To generate the list of "last updated user” and "origin":
Please note, only Learning Administrator can retrive this data.
- Go to Learning Administration
- Access the Reports section
- Search for the User Learning Plan Audit Report
- Access the report and filter based off the User and Item
- Schedule Job
- Download the report after completion
- Check the Action column for Insert to know when the item was first added to the Learning Plan while cross referencing the Origin Column to validate that it was added via CDP
Once the two list is ready, the SuccessFactors Support can create an internal ticket (incident) in which our engineering team will process the script.
We will need your approval and confirmation to run the script understanding that this change cannot be reversed.
Please refer to our Best Practices KBA for opening cases with Support and reference this article when creating the case in our Portal.
IMPORTANT: Although mentioned above, we would like to mention again that all of the following are needed for support to proceed with creating the request for the script to be created and ran.
- The export files of the report mention above.
- Confirmation to run the script understanding that this change cannot be reversed.
Please ensure all these are included within the ticket prior to creating, or support will not be able to proceed with the case.
NOTE: The configured status must be the same for Learning Activities Template and Development Plan template, otherwise the system will not allow the to complete a Development Goal.
Keywords
SuccessFactors, Learning, CDP, LMS, career development plan, learning activity, status, planned, completed, synchronization, LMS, activities , KBA , LOD-SF-CDP-LA , Learning Activity Plan (LMS) , LOD-SF-LMS , Learning Management System , LOD-SF-LMS-CDP , Career Development Program , Known Error