SAP Knowledge Base Article - Public

2198663 - Tasks and Surveys Not Assigned Automatically to Visits

Symptom

The Tasks and the Surveys are not automatically assigned to the Visits even though the rules are defined in Activity Planner Work Center.

Environment

sap Hybris Cloud for Customer 1711/04

Reproducing the Issue

  1. Go to Visits Work Center.
  2. Go to the Visits Tab.
  3. Click in the Button New.
  4. Fill all requested information.
  5. Select Save and open.
  6. New created visit will be opened.
  7. Go to the Tasks or Survey Tab.
  8. Here you will be able to see  the tasks and surveys are not automatically assigned based on the rule defined in Activity Planner Work Center.

Cause

There is a batch job in the backend for automatic assignment runs every 7 minutes for a period of 5 mins. Hence, it is fair to assume that the tasks and surveys will get generated in about 8 to 12 minutes from the time of visit creation

Resolution

In case if user cannot wait then this can be triggered manually. To do this you can click on Action ->"Refresh visit" to trigger synchronous update. The tasks and surveys reflect ad soon as you select “Refresh Visit”.

Keywords

Activity Plan ; Visits ; Automatically , KBA , LOD-CRM-ACT-VST , Visit Planning , How To

Product

SAP Cloud for Customer add-ins all versions