Symptom
There is a business rule triggering to change the value of a field (X).
The business rule however only triggers this change with user A but not with user B.
Reproducing the Issue
In the system you have defined a business rule in such a way that field X is always equal to field Y.
- When user A makes a change to field Y, after saving these change you can see that field x changed accordingly to what you defined in the rule > so the rule triggered correctly
- When user B makes a change to field Y and saves these changes, you can see in the records that the field X maintained it's original value, so the rule didn't trigger.
Cause
Permission Roles assigned to user B are preventing him to have Edit/Insert rights over the field X.
Resolution
Please assign Edit/Correction rights to the permission role assigned to User B so that when he makes changes to field Y the business rule can edit field X.
Keywords
rules does not trigger some not all Employee Central MDF rules , KBA , rbp , role based permissions , LOD-SF-EC-RBP , Roles & Permissions (EC Core only) , LOD-SF-EC-JOB-RUL , Job Info Business Rules , Problem