SAP Knowledge Base Article - Public

2206022 - SAP Lumira cannot connect to Central Management Server

Symptom

SAP Lumira cannot connect to Central Management Server

Trace Logs show "java.net.SocketException: Unknown proxy type : HTTP"

Environment

  • SAP Lumira
  • SAP BusinessObjects Buiness Intelligence Platform

Reproducing the Issue

  1. Install SAP Lumira
  2. Configure HTTP type proxy
  3. Try to acquire data from a Universe on the SAP BusinessObjects Business Intelligence Platform

Cause

SAP Lumira currently includes Java 7

Java 7 only works with SOCKS and DIRECT proxies

http://bugs.java.com/view_bug.do?bug_id=6370908

Resolution

Best solution is to use a SOCKS or DIRECT proxy.

If the only option is HTTP proxy then SAP Lumira can be configured to use Java 8.

  1. Download and install Java 8 from http://www.oracle.com/technetwork/java/javase/downloads/jre8-downloads-2133155.html
  2. Point SAP Lumira to Java 8 by adding the following two lines to the very top of c:\program files\sap lumira\saplumira.ini:
    -vm
    C:\Program Files\Java\jre1.8.0_51\bin
  3. NOTE: The path depends on the exact version of Java 8 that you install

Keywords

BIP BI proxies connections failure failed network settings , KBA , BI-LUM-DIS , Lumira Desktop/Discovery , Problem

Product

SAP Lumira, desktop edition 1.0