Symptom
You have activated the soution finder, but when searching on it, system does not return any result.
Reproducing the Issue
- Go to the Service work center.
- Go to the Tickets view.
- Open any ticket.
- In the Solution Finder search field, input any key word and click Search button.
- No results.
Cause
You have activated Use JAM as Knowledge Base feature. This takes precedence over Mindtouch if activated so recheck the settings in the Business Configuration work center.
Resolution
Solution Finder is Not Returning any Result using Knowledge Base Integration (Base Data Mashup like MindTouch)
- Go to the Business Configuration work center.
- Go to the Implementation view;
- Select the implementation project and click Edit Project Scope;
- Go to the step 4-Questions;
- Click Next > until you reach Questions;
- In the Scoping Elements list select -> Customer Care -> Service Request Management;
- Enable the follow question "Do you want to enable the knowledge base integration feature of the agent workspace" ? by selecting Yes for that question;
- Click Next;
- Review and confirm your project scope;
Note:
- After Enabling Knowledge Base Integration option as described above please make sure that you create a Knowledge Base Web Service + Knowledge Base Data Mashup
- The name of Data Mashup must be KNOWLEDGE_BASE
- As you are using Data Mashup make sure you did not mark the scope question SAP JAM as knowledge base provider as described below. This takes precedence over mindtouch if activated and no results will appear.
After that verify the Solution Finder from any ticket screen. The results will be loaded correctly.
Solution Finder is Not Returning any Result using SAP JAM as knowledge base provider.
- Go to the Business Configuration work center.
- Go to the Implementation view;
- Select the implementation project and click Edit Project Scope;
- Go to the step 4-Questions;
- Click Next > until you reach Questions;
- In the Scoping Elements list select -> Customer Care -> Service Request Management;
- Enable the follow question "Do you want to use SAP JAM as knowledge base provider" ? by selecting Yes for that question;
- Click Next;
- Review and confirm your project scope;
Note:
- The solution finder will only search for documents under Content folder in JAM group. Check and upload the documents in Content section instead of knowledge base folder.
After that verify the Solution Finder from any ticket screen. The results will be loaded correctly.
Keywords
KBA , LOD-CRM-SRP , Service Request Processing , How To