SAP Knowledge Base Article - Public

2208539 - Not able to see People Search - Home Page

Symptom

The "People Search" or "Action Search" is not available in your instance.

"Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental."

Environment

SAP SuccessFactors HCM Suite

Reproducing the Issue

  1. Go to home page;
  2. Check the People/Action Search on the header of the instance:

People Search.PNG

Cause

This missing functionality may be caused due to the following:

  • User Directory is disabled for your instance. "People Search" uses the Directory as a mechanism to find the users in your instance, if it is disabled then People Search will not be available for any user;
  • The user does not have the necessary permissions.

Resolution

First, it is necessary to verify if User Directory is enabled in your instance. To do so, please follow below steps:

  1. Go to Admin Center > Company Settings > Platform Feature Settings;
  2. Enable the option "User Directory".

Once this feature is enabled, users must have the following permissions enabled:

  1. Go to Admin Center > Update User Permission>  Manage Permission Roles;
  2. Select the desired permission role;
  3. Click "Permission";
  4. Under "General User Permission", select the permissions "Company Info Access" and "User Search".

Keywords

People Search, Action Search , KBA , LOD-SF-PLT , Platform Foundational Capabilities , LOD-SF-PLT-SRH , Search , How To

Product

SAP SuccessFactors HCM suite all versions