Symptom
A user created a job requisition and wants to add Competencies from Competency Libraries. He doesn't see some - or none - of the competencies uploaded to the system. However, the other user, e.g. Recruiter or Approver, can see all of the competencies and can add them to the job requisition. Why is that?
Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental.
Environment
SAP SuccessFactors Recruiting Management.
Reproducing the Issue
Admin Tools - Competency Libraries:
Creating a Job Requsiition:
Cause
The reason for this behavior is that the Competencies have been configured only in selected languages (e.g. English US or Dutch). If a user uses a different language he is not able to see the competencies as they are not configured for his language.
Here the competencies have been set only to English US:
However, a user uses English UK, hence he will not see any of the competencies:
Here we can see a competency has been configured also in Dutch, so the user using Dutch language will be able to add it to a Job Requisition:
Resolution
Whenever creating Competency Libraries make sure to configure it for all the languages used by recruiters.
See Also
2086613 - Top 10 Reasons Competencies Not Showing in Form
Keywords
Competency Library , KBA , LOD-SF-RCM-JOB , Job Postings & Requisitions , Problem