Symptom
- System throws error while updating details of an employee under profile.
- Second Manager Cycle Detected while updating user records via Employee import.
- Import failed giving error second manager cycle detected.
- Invalid Second Manager (Cycle detected)
Environment
- SuccessFactors Cloud HCM
- Employee Central
Reproducing the Issue
- Logon to the instance as a system administrator.
- Navigate to profile of the employee and edit respective information as per the requirement.
- On saving the updated data, system throws an error stating "Second Manager Cycle Detected. Please try again."
- This behaviour can also be experienced while updating records via scheduled employee imports or peforming manual employee import via Admin Tools>Employee Import.
Cause
- When the Job Relationships are being updated from the Position Sync, the Second Manager Assigned to the Position is causing a Cycle to be formed in the Position Hierarchy
- Second Manager cycle is mainly a check performed at hierarchy level.
- Eample:
- Check ensures that hierarchy is NOT redundant in nature.
- For instance, we have two employee for a single Legal Entity: Manager A and Human Resources B
- The most commonly captured error is A's HR is B, and B's manager is A.
- In more generic terms, User A's second manager is User B, and User B's second manager is User A.
Resolution
- SuccessFactors administrators are advised to avoid any such redundant hierarchy in the system.
- The top level hierarchy can be updated with No Manager or No HR.
- The Position Hierarchy will need to be reviewed to spot the cycle
Keywords
Manager cycle detected, Unable to update profile details, Employee import failed, Manager wrongly updated, , KBA , LOD-SF-EC-PER-PRS , Personal Info - Config, Rules, RBP, UI , Problem
Product
SAP SuccessFactors Employee Central all versions ; SAP SuccessFactors HCM Core all versions