Symptom
A third-party sales order was canceled. However, it has been noticed that the corresponding customer demand has the cancellation status as Cancelation Requested. It is expected that the cancellation status change to Canceled.
Environment
SAP Business ByDesign.
Reproducing the Issue
- Go to Outbound Logistics work center.
- Navigate to Customer Demand view.
- Search for the sales order which it was canceled.
The cancellation status of customer demand document is Cancelation Requested.
Cause
When a third-party sales order document is released, system will create a third-party purchase order document as well. It was created a PO Acknowledgement against this third-party purchase order which has quantity deviations. These quantity deviations have not yet been accepted. Once these deviations are accepted the cancellation status of customer demand will be updated to Canceled.
Resolution
- Go to Purchase Requests and Orders work center.
- Navigate to Purchase Orders view.
- Search the relevant third-party purchase order, select it, and choose the Edit button.
- In Edit screen of the purchase order, select the link Check Deviating Purchase Order Acknowledgment which is visible on the top left-hand side of the screen.
- Choose Yes or No on the dialogue box that is displayed as per your business requirement.
- In PO acknowledgement screen choose the button Accept Deviation.
- The purchase order will be cancelled and also the cancelation status of customer demand document will be updated to Canceled.
Please note that the purchase order will be cancelled automatically only of the Supplier Status in PO Acknowledgement document is Rejected. If the Supplier Status is Accepted, it will have to explicitly cancel the purchase order document from your end. This will update the cancellation status of the customer demand.
Keywords
Third-party sales order, Cancelation Requested, PO Acknowledgement , KBA , AP-CR-CR , Customer Requirement , How To