SAP Knowledge Base Article - Public

2217113 - DUPLICATE_USERNAME : Failed to add/update user / error occurs while changing Username of an employee - SFAPI

Symptom

The below error appears while updating/upserting "username" for an employee in Successfactors.

DUPLICATE_USERNAME : Failed to add/update user [XXXX] "XXX YYYYY" (N/A;N/A;N/A): Duplicate Username - "XXXX".

This error can appear either when an API is used to upsert or a csv import is used to upsert in Successfactors.

Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental.

Environment

  • SuccessFactors
  • BizX

Reproducing the Issue

In this article, We will reproduce the issue via API

Entity used - User (SFAPI)

Operation - Upsert

1. Let us create a User as shown below.

dup1_edit.jpg

We can see that a new user is created in the system (Successfactors)

2) Now, Change the username from "abc" to "123"

dup2_edit.jpg

We can observe that the API call has a error status and the Upsert operation was not successful.

Cause

The Username "123" exists in the company. This upsert request is trying to add a duplicate entry and hence is rejected.

How can we verify if the provided username really exists in the Successfactors instance ?

Navigate to Admin Center - Employee Export - Export User File.

We can check from the USERNAME column in the excel file if the provided username already exists. This is shown below:

dup3_edit.jpg

FYI - USERID in the above column B is the externalId in our SOAP request.

Resolution

We can see that the username "123" already exists and is assigned to an employee by the name Example User

For this reason, The import engine of successfactors doesn't accept the same Username for another employee.

The following points have to be noted.

1) Username has to be Unique and NO two users in an instance can share the same username.

2) Username is case-sensitive ie, usernames like abcd and ABCD are treated like two different users.

3) You cannot see username on the Successfactors UI. This is visible in the user data file. Navigate to Admin Center - Employee Export - Export User File.

To Fix these errors,

Please Use Unique Username.

See Also

SAP SuccessFactors HCM Suite SFAPI: Developer Guide

Keywords

Duplicate username , Unable to change username , Failed to update user, DUPLICATE_USERNAME : Failed to add/update user, SFAPI , KBA , LOD-SF-INT-API , API & Adhoc API Framework , LOD-SF-INT , Integrations , Problem

Product

SAP SuccessFactors HXM Suite all versions