Symptom
- When creating an Offer Approval mandatory fields are blank when sent to approver for final approval.
- Why are fields blanks when Offer is sent for Approval?
- Custom Picklist fields are blank when sending Offer for Approval
Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental.
Environment
SAP SuccessFactors Recruiting Management
Reproducing the Issue
- Go to candidate's application in Candidate Summary → click on Action → Offer → Offer Approval
- Fill the fields, fill the ad hoc approver if necessary
- Click on 'Send to Approver'
- The picklist fields will be blank
Cause
This happens because the affected fields are 'customPicklist', and they have their attributes set as custom="false".
Resolution
The fields 'customPicklist' in Offer Details template must be set as custom="true".
In order to fix this you have two options:
- Option 1: Change the field in the XML
- Check if the fields that are giving this problem have the field ID 'customPicklistX', where X is the number;
- If the field ID is a 'customPicklist' and the custom attribute is setup to custom="false", this will need to be changed to custom="true".
- As this constitutes an XML change, please follow the following process:
KB article 2258199 - SCR Form: XML Software Change Request for Requisitions and Recruiting Management - Recruiting
In case you have Multi-Stage Application, please, contact your partner.
- Option 2: Change it through Manage Templates
IMPORTANT: Keep in mind this tool is extremely powerful. Modifications made to templates can have a direct impact on candidate experience, integrations, custom integrations, etc. Change should only be made by a qualified individual that is familiar with the configuration.
- Go to Admin Center > Recruiting > Manage Templates > Offer Details
- Select the template that has the affected custom Picklists
- Click on '## Fields defined. Click to modify
- Click on Add > Add Standalone field
- Fill the information as the same of the affected picklist, even the fieldID
- Delete the old picklist field (for not happen any inconsistency in the system)
Note: If you choose Option 2, removing the old field, the data once filled in it will not show up in reports. Hence, for reporting purposes, the first option would be a better choice.
- If user want to report on these fields, and if they are associated with the Job Requisition or Candidate Application template, follow KB article 2081508 on how to make them reportable.
- In case you don't have Manage Templates enabled in the instance, see KB article 2365214 - Manage Templates for Recruiting Management
See Also
Keywords
fields blank, disappear, SF, success factors, RCM , KBA , LOD-SF-RCM-CAO , Candidate Offers, Offer Letters , Problem