SAP Knowledge Base Article - Public

2219808 - Offer Approval Field Values (customPicklist) are Empty When Saving/Sending Offer to Approver - Recruiting Management

Symptom

  • When creating an Offer Approval mandatory fields are blank when sent to approver for final approval.
  • Why are fields blanks when Offer is sent for Approval?
  • Custom Picklist fields are blank when sending Offer for Approval

Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental.

Environment

SAP SuccessFactors Recruiting Management

Reproducing the Issue

  1. Go to candidate's application in Candidate Summary → click on Action → Offer → Offer Approval
  2. Fill the fields, fill the ad hoc approver if necessary
  3. Click on 'Send to Approver'
  4. The picklist fields will be blank

Cause

This happens because the affected fields are 'customPicklist', and they have their attributes set as custom="false".

Resolution

The fields 'customPicklist' in Offer Details template must be set as custom="true".

In order to fix this you have two options:

  • Option 1: Change the field in the XML
  1. Check if the fields that are giving this problem have the field ID 'customPicklistX', where X is the number;
  2. If the field ID is a 'customPicklist' and the custom attribute is setup to custom="false", this will need to be changed to custom="true".
  3. As this constitutes an XML change, please follow the following process:

    KB article 2258199 - SCR Form: XML Software Change Request for Requisitions and Recruiting Management - Recruiting

In case you have Multi-Stage Application, please, contact your partner.

  • Option 2: Change it through Manage Templates

IMPORTANT: Keep in mind this tool is extremely powerful. Modifications made to templates can have a direct impact on candidate experience, integrations, custom integrations, etc. Change should only be made by a qualified individual that is familiar with the configuration.

  1. Go to Admin Center > Recruiting > Manage Templates > Offer Details
  2. Select the template that has the affected custom Picklists
  3. Click on '## Fields defined. Click to modify

ManageTemplates1.png

  1. Click on Add > Add Standalone field

ManageTemplates2.png

  1. Fill the information as the same of the affected picklist, even the fieldID
  2. Delete the old picklist field (for not happen any inconsistency in the system)

Note: If you choose Option 2, removing the old field, the data once filled in it will not show up in reports. Hence, for reporting purposes, the first option would be a better choice.

  • If user want to report on these fields, and if they are associated with the Job Requisition or Candidate Application template, follow KB article 2081508 on how to make them reportable.
  • In case you don't have Manage Templates enabled in the instance, see KB article 2365214 - Manage Templates for Recruiting Management

See Also

  • KB article 2258199 - SCR Form: XML Software Change Request for Requisitions and Recruiting Management - Recruiting
  • KB article 2081508 - Custom Reportable Recruiting Fields - Recruiting Management
  • KB article 2365214 - Manage Templates for Recruiting Management

Keywords

fields blank, disappear, SF, success factors, RCM , KBA , LOD-SF-RCM-CAO , Candidate Offers, Offer Letters , Problem

Product

SAP SuccessFactors Recruiting all versions