Symptom
- When creating an Offer Approval, standalone custom fields (customString, customLong, customPicklist or customDate) are blank after sending it to the approver.
- Why are fields blank when the offer is sent for approval?
- The customPicklist fields are blank when sending offer for approval.
Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental.
Environment
SAP SuccessFactors Recruiting Management
Reproducing the Issue
- Go to candidate's application in Candidate Summary → click on Action → Offer → Offer Approval
- Fill the fields, fill the ad hoc approver if necessary
- Click on 'Send to Approver'
- The standalone custom fields will be blank
Cause
- Standalone Offer Approval custom fields are set as custom="false" instead of custom="true".
- Standalone Offer Approval custom fields are defined with an incorrect field type. For example, a customString field is set as a number type instead of a text type.
Resolution
1. The standalone custom fields (customString, customLong, customPicklist and customDate) in Offer Detail template must be set as custom="true".
In order to fix this you have two options:
- Option 1: Change the field in the XML
Check if the fields that are giving this problem have the field ID 'customStringX', 'customLongX', 'customPicklistX' and 'customDateX', where X is the number;
For example, if the field ID is a 'customPicklist' and the custom attribute is setup to custom="false", this will need to be changed to custom="true".
As this constitutes an XML change, please follow the following process:
KB article 2258199 - SCR Form: XML Software Change Request for Requisitions and Recruiting Management - Recruiting
In case you have Multi-Stage Application, please, contact your partner.
- Option 2: Change it through Manage Templates
IMPORTANT: Keep in mind this tool is extremely powerful. Modifications made to templates can have a direct impact on candidate experience, integrations, custom integrations, etc. Change should only be made by a qualified individual that is familiar with the configuration.
- Go to Admin Center > Recruiting > Manage Templates > Offer Details
- Select the template that has the affected fields
- Click on '## Fields defined. Click to modify
- Click on Add > Add Standalone field
- Fill the information as the same of the affected field, even the Field ID
- Delete the old field (for not happen any inconsistency in the system)
Note: If you choose Option 2, removing the old field, the data once filled in it will not show up in reports. Hence, for reporting purposes, the first option would be a better choice.
- If user want to report on these fields, and if they are associated with the Job Requisition or Candidate Application template, follow KB article 2081508 on how to make them reportable.
- In case you don't have Manage Templates enabled in the instance, see KB article 2365214 - Manage Templates for Recruiting Management
2. Standalone custom fields must be defined using the appropriate field type as per the Field ID
Field ID | Field Data Type |
customString1 – customString15 | text |
customLong1 – customLong10 | number |
customDate1 – customDate10 | date |
customPicklist1 – customPicklist10 | picklist |
See Also
- KB article 2258199 - SCR Form: XML Software Change Request for Requisitions and Recruiting Management - Recruiting
- KB article 2081508 - Custom Reportable Recruiting Fields - Recruiting Management
- KB article 2365214 - Manage Templates for Recruiting Management
- KB article 3310127 - After Making a Job Requisition (or Application) Custom Field Reportable the Values are Missing in the existing Offer Approvals
Keywords
fields blank, disappear, SF, success factors, RCM, Standalone, Offer Detail, Offer Approval, customString, customDate, customPicklist, customLong, number, text , KBA , LOD-SF-RCM-CAO , Candidate Offers, Offer Letters , Problem