Symptom
When attempting to save an address for an employee record the system generates an application error.
Cause
In this case the "state" HRIS field was associated with a non-existent picklist in the "homeaddress" HRIS element of the "CSF-for-succession-DM.xml" data model.
For example:
<country id="CAN">
<hris-element id="homeAddress">
<hris-field max-length="256" id="state" visibility="both" required="true">
<label>Province</label>
<picklist id="STATE_CAN"/>
</hris-field>
</hris-element>
</country>
Where the picklist referenced, "STATE_CAN", did not exist in the picklist database.
Resolution
To correct the problem a valid and appropriate picklist was referenced instead of the non-existent picklist.
For example, the picklist reference "STATE_CAN" was replaced with "PROVINCE_CAN".
<country id="CAN">
<hris-element id="homeAddress">
<hris-field max-length="256" id="state" visibility="both" required="true">
<label>Province</label>
<picklist id="PROVINCE_CAN"/>
</hris-field>
</hris-element>
</country>
Keywords
Home Address, Corporate Address, homeAddress, corporateAddress, Picklist, Application Error , KBA , LOD-SF-EC , Employee Central , Problem