Symptom
This article provides information about users unable to access Onboarding 1.0 and error below is received:
'Your Seamless login has failed. Please contact your system administrator.'
"Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental."
Environment
SAP SuccessFactors Onboarding 1.0
Reproducing the Issue
- Navigate [ SAP SuccessFactors HCM > Onboarding 1.0 ]
- Error is received
Cause
To resolve the issue, understand first the problem with scenarios below and once identified follow the steps on how to resolve each scenario.
- Scenario 1: A specific user have reported the issue and most of the users are able to access
- Scenario 2: Multiple users reported the issue
- Scenario 3: All users are affected and unable to access Onboarding 1.0
- Scenario 4: User is not available in SAP SuccessFactors HCM > Onboarding 1.0 > Security > Users
- Scenario 5: Onboarding 1.0 User Sync is not running or not configured
- Scenario 6: Candidate created manully in onboarding system
Resolution
Scenario 1: Identify
- Identify the 'USERID' of the affected user, administrators can verify this via Ad-Hoc reporting tool or Manage Users (Non-EC).
- Navigate [ SAP SuccessFactors HCM > Onboarding 1.0 > Security > Users ] and use the search function with the filter 'LoginName'
- Enter the 'USERID' and find out if the user is available.
- Search result is complete and no user is available with same 'LoginName'
Scenario 1: Fix
- Navigate [ SAP SuccessFactors HCM > Onboarding 1.0 > Security > Users ]
- Click 'Create' button
- Fill-out employees information
Field Field Description Required Login Enter the BizX USERID Yes First Name First name of affected user Yes Middle Name Middle name of affected user Last Name Last name of affected user Yes Password Onboarding 1.0 Password Confirm Password Confirm Onboarding 1.0 Password Yes Email E-mail of affected user Security Question List of Security Question Yes Security Answer Employees Answer to the Security Question Yes Title Title of the affected user PJCode External Id Delegate - Click 'Create' button to saved changes
- Ask affected user to clear the internet browser's history and cache and try to access again
Scenario 2: Identify
- Follow the scenario 1 identification steps
- If affected users is not available in [ SAP SuccessFactors HCM > Onboarding 1.0 > Security > Users ], it is probably the user sync is not running or not configured
Scenario 2: Fix
- Engage with SAP SuccessFactors Cloud Product Support by logging in an SAP Expert Chat or by creating a support case. Provide the following information
- The list of all affected users include their Complete Name, UserID, or UserName
- When did the issue first reported? Provide specific time and date
- BizX Company ID and Support Access
Scenario 3: Identify
- All Hiring Managers and Recruiters are unable to access Onboarding 1.0
Scenario 3: Fix
- Please check what are the BizX accounts ID are connected to the Onboarding account ID, it can be only one to one
- Engage with SAP SuccessFactors Cloud Product Support by logging in an SAP Expert Chat or by creating a support case. Provide the following information
- The list of all affected users include their Complete Name, UserID, or UserName
- When did the issue first occured? Provide specific time and date
- BizX Company ID and Support Access
Scenario 4 - 5: Identify
- User Sync is not properly configured and the user or permission is not present in Onboarding
Scenario 4 - 5 - 6: Fix
- 2251425 - How to Validate if Foundation Import (User, Permission, and Corporate Structure Sync) is Working [Integration with BizX] - Onboarding 1.0
- 2278872 - User Sync Issue and Fix - Onboarding 1.0
Scenario 5: Identify + Fix
See internal Memo
Additional Information
- If user is part of the 'System Admin' Role Based Permission Group, user will not be able to access Onboarding 1.0 .
- Another area to check is BizX and Onboarding 1.0 is not properly integrated.
- If the jobs are configured correctly and the file is being picked up from SFPT, but the seamless login error still persists, please create a support ticket. We will then raise a ticket to operations to clear the cache.
Keywords
SF, Success, Factors, Onboarding 1.0, OBD, ONB, LOD-SF-OBD, Seamless, Login, Failure, Unable, Access, Permission, User, Sync, Foundation, Import, KMS.XpressHR.SSO.SAML20.AssertionConsumerService, Certificate serial# , KBA , LOD-SF-OBD-INT , Integrations with Onboarding , LOD-SF-OBD-SYS , System Performance, Usability, Errors, Security , Problem