Symptom
- The following symptoms are occuring in the salesdemo systems:
- The following error is observed when trying to import even a vanillaCountry Specific Succession Data model for the instance (in Provisioning): "Invalid country code USA mentioned. Only 3-letter ISO codes for countries are supported".
- Unable to modify or add personal information due to empty picklist for any country specific picklists. These picklists come up blank.
- Unable to add new employee due to unable to choose value from mandatory country related picklists.
- Unable to maintain Country value in any Country drop-down menu (e.g. when setting Corporate Address for a Location FO)
"Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental."
Environment
- SuccessFactors HCM
- This has been observed on certain instances on SalesDemo 8 (DC8)
Reproducing the Issue
There are various ways of reproducing the issue, but here is one example:
- Log on to your instance
- Go to Admin Center
- Choose to "Add New Employee"
- Fill in any mandatory fields for this employee.
- Note when you try to pick a value from "Country of Birth" the picklist is empty
- Click on Next to go to "Personal Information" part, and try to fill in the mandatory "Country" field under the "Home Address" section. You are unable to do this due to no value in picklist
Also can try -:
- Navigate to Admin Center > Manage Organisation, Pay and Job Structures
- Edit a Location
- Try to set Country value for Corporate Address
- Country drop-down is blank
Cause
- The reason for this is that some of the database views are corrupted
- It typically happens when an instance has been cloned from another instance on the same Data Center
Resolution
This is fixed by turning all of the the "Employee Central V2" related settings in Provisioning off and then on again
Go to Provisioning and choose "Company Settings" area. In there you will need to disable the following settings and save, and then reselect these setting and save again. Please follow these next steps exactly -:
- Login to Provisioning
- Navigate to Company Settings
- Disable RBP > Role-based Permission (This will disable Administrative Domains)
- Go back to Company listing
- Navigate to Monitor Jobs (in Provisioning)
- Check that the job convertTerritoryToView is listed in "Waiting Jobs" - this will be executed as per Next Executing Time
- Wait for the “convertTerritoryToView” job to completed (note that for instances located on Salesdemo, it may take 10+ minutes for the job to start - please be patient).
- Go back to Company Settings
- Enabled RBP again
- Go back to Monitor Jobs and check a new job for convertTerritoryToView has been created and completed
- By recycling (turning off/on) the Role-based Permission (This will disable Administrative Domains) setting, the database view for Territoiry (which is used by Country related Picklists/Objects) is regenerated.
PLEASE NOTE THAT THIS ISSUE IS RESOLVED IN THE B1605 RELEASE AND ONLY IMPACTS NEW OR MIGRATED INSTANCES - ECT-47304
Keywords
Country picklist empty, Territoiry, View, Employee Central V2, Effective Dated Data Platform, Invalid country code USA mentioned. Only 3-letter ISO codes for countries are supported, data model , KBA , LOD-SF-EC-BCI , Manage Business Configuration (BCUI) & Data Models (XML) , LOD-SF-EC-PRV , Provisioning Changes , Problem