Symptom
When trying to add a password protected file to a ticket, system does not allow you to do so.
Environment
SAP Cloud for Customer
Reproducing the Issue
- Go to the Service work centre.
- Go to the Tickets view.
- Open ticket XYZ (XYZ represents the ID of the ticket).
- Go to the Attachments tab.
- Select Add > Local File.
- Select password protected / encrypted file.
Error message: "Password-protected compressed file" is shown.
Cause
The error message relates to the virus scan being unable to scan the file content when it is password protected and, therefore, will not allow the file to be uploaded.
Resolution
- The scenario described is an expected system behaviour.
- Changes will be possible due to security reasons per our SAP's security policy.
- The system has a Virus Scan that cannot check password-protected / encrypted files, which blocks this type of attachment.
- To adjust this behaviour, you may raise an case so our Operations team can proceed to disable the Virus Scan for password-protected files.
- In the case, customers must acknowledge that changing the virus scanner settings upon your request will mean that:
- the virus scanner will only raise warnings if it cannot scan a file (e.g. due to encryption),
- to keep the security level, files need to be scanned before encryption, and the parties downloading files should have on-access virus protection active.
- As an alternative, you may remove the password protection from the file.
- Customers can also use 7z protected files as those can be scanned even with password protection.
See Also
2584828 - Password Protected Microsoft Office Files Cannot Be Uploaded
Keywords
Attachment, File, Password Protected, Encrypted , KBA , attachment , password protected , SRD-CC-FED , Feeds , How To
Product
SAP Cloud for Customer add-ins all versions