Symptom
When you try to post a time off request for the following year the system shows a negative balance.
Reproducing the Issue
- Login into the instance
- Go to Employee File
- Go to Time Off
- Select one or more days in the following year
You will see that the balance will show a negative amount of days to book from. This is preventing you to post your time off request.
Cause
Check the following scenarios:
- Please ensure, in Manage Time Off Calendars, that you have ran the current year's accrual rule.
- Check for this Time Account type that you have not set Simulate Accruals to yes.
- For the Time Account type check the end date until when the days are bookable.
- In Time Account type details find the field Balance cannot Fall Below and confirm the remaining days in your Balance.
Resolution
1. Go to Manage Time Off Calendars,
2. Find your current year's accrual rule
3. Run this accrual rule
[NOTE: if this is not the first time running this rule please select the box With Recalculation]
4. After the rule has ran open the Time Account Type
5. Find the field Simulate Accruals
6. Set this to No
Now the Balance in Time Off should be accurate
Keywords
KBA , LOD-SF-EC-TIM , Time Off , Problem