SAP Knowledge Base Article - Public

2231503 - Synchronize Business Configuration Job Configuration via Scheduled Job Manager

Symptom

Details on the Synchronize Business Configuration Job Type availability via Scheduled Job Manager including details on the job execution limit. 

Environment

SAP SuccessFactors Employee Central 

 

Cause

With the 1H 2023 Release a series of Employee Central jobs were enhanced to include job execution guardrails, this include the Synchronize Business Configuration job.

This was documented in the following What's New View pages:

This enhancement is part of an ongoing effort to make Scheduled Job Manager the central self-service tool for managing and monitoring scheduled jobs. These job execution guardrails are part of these efforts, to ensure the jobs can be used in the self-service tool in a supported and controlled manner.

For a full list of Jobs which now have guardrails outside of Employee Central, please review the following section of the guide: 
Managing Scheduled Jobs: Notes on Some Common Job Types

Resolution

Job Failure due to Execution Limit: 

If the Synchronize Business Configuration job fails due to execution limitations it will detail the following error in the Job Details:

  • job failed because it exceeded the daily scheduling threshold for execution

If a job fails due to this job execution guardrails, it is recommended to review the configuration of the job and adjust the recurrence to ensure it complies with the job execution guardrails detail in the WNV: ECT-207756: More Employee Central Jobs on Job Scheduler in Scheduled Job Manager

To do this please ensure you have the required permission to access Scheduled Job Manager from the Admin Center.

This requires you have the permission:

  • Administrator > Admin Center Permissions >  Monitor Scheduled Jobs
  • Administrator > Admin Center Permissions > Manage Scheduled Jobs

Different job types might have additional module-specific permission controls. Check module guides to know all the details, please review the links with the "Related Information" of the WNV page for links to each of these relevant jobs: ECT-207756: More Employee Central Jobs on Job Scheduler in Scheduled Job Manager

Steps to change the recurrence of a job:

  1. Ensure you have the required permission detailed above 
  2. Navigate to Scheduled Job Manager
  3. Select "Job Scheduler" Tab 
  4. Filter for the desired Job Type
  5. For the desired job select Actions> Cancel 
  6. Once the job is canceled select Actions> Edit 
  7. Adjust the recurrence to comply with the job execution guardrails
  8. Ensure all required fields are filled out 
  9. Submit

FAQ:

Q:If we manually trigger the Synchronize Business Configuration job from Provisioning, will that run be counted in the job execution guardrails?
A: Yes, can run in both the Admin Center and Provisioning, and the execution limits don't consider which tool is used to schedule the job.

Q: Why does the Synchronize Business Configuration job fail if it is created from Admin Center > Scheduled Job Manager for the first time?
A: It is currently not supported to create the Synchronize Business Configuration job from Admin Center > Scheduled Job Manager. As mentioned in the What's New Viewer,: ECT-209082: Synchronize Business Configuration Job Availability in Scheduled Job Manager it is currently only supported to manage and monitor the Synchronize Business Configuration job using the Scheduled Job Manager in Admin Center. This job should be created for the first time via Provisioning as part of implementation of the Data Models have been initially loaded. If you are enabling Business Configuration UI for the first time, please review the following section of the guide: Implementing and Managing Business Configuration (BCUI): Synchronizing the Succession Data Model with Business Configuration UI

Q: When editing a Synchronize Business Configuration job from Admin Center > Scheduled Job Manager the "Send Emails When Job Starts" check box/setting is unselectable? 
A:
This is by design, when this job is edited via Admin Center -> Scheduled Job Manager, the checkbox of "Send Emails When Job Starts" will be disabled and unselected. As a best practice we do not recommend using this setting for this job type as it is considered a simple job type by Product Management.

Q: When editing a Synchronize Business Configuration job from Admin Center > Scheduled Job Manager the "Send Emails When Job Fails " check box/setting can't be changed? 
A:
This is by design, when this job is edited via Admin Center -> Scheduled Job Manager, the checkbox of "Send Emails When Job Fails" will automatically selected. As a best practice we recommend using this setting for this job type and so it set by default.

See Also

 3329464: Employee Central Scheduled Jobs Fail with Error:  job failed because it exceeded the daily scheduling threshold for execution

Keywords

Synchronize Business Configuration, sync business configuration, Synchronise Business Configuration, ECT-207756, Scheduled Job Manager, ECT-209082 , KBA , LOD-SF-EC-BCI , Manage Business Configuration (BCUI) & Data Models (XML) , Problem

Product

SAP SuccessFactors Employee Central all versions ; SAP SuccessFactors HCM Core all versions

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