Symptom
You have a requirement to modify the existing Appointment for some fields. So, you left the Status field empty of those Appointments.
After migration, the status of the Appointments changed to Open.
Cause
The default status for an Appointment is Open. So, if you leave the field empty, system consider it as Open and hence, the status changed.
Resolution
If your requirement is to modify the existing Appointment, the preffered option is to use Mass Data Maintenance.
When you export the CSV file through Mass Data Maintenace, do not change the status and retain the current status during import aswell.
Keywords
KBA , LOD-CRM , Cloud for Customer , How To