Symptom
As an admin, upon navigating to a User's Record, when attempting to update the Required Date field of an assigned item, the Edit option (pencil button) is not available
Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental.
Environment
SAP SuccessFactors Learning
Cause
The administrator is missing one to two permissions to the role. The permission required to be added to the administrator role needs to be evaluated by your business needs and setup.
Resolution
Checking the admin's role:
- At Learning Administration > System Administration > Security > Administrators >
- Search for the admin ID > open the record > Assigned Roles tab
Checking the role's permission:
- At Learning Administration > System Administration > Security > Role Management >
- Search for the role ID > open the record in the Edit mode > Permissions tab >
- Click on "add one or more from list" > Expand all > select the permissions "Edit Item Assigned to User (domain restricted by item)" and "Edit Item Assigned to User (domain restricted by user)" >
- Hit Add >
- The administrator should then be able to update the Required Date field on the User's Record.
See Also
KBA 2774845 - Questions regarding Learning Permissions, Roles, and Restrictions
Keywords
required date admin permission role security unable edit modify update change item sf lms successfactors course , KBA , lmsadminui , LOD-SF-LMS-WOR , Roles & Workflows , LOD-SF-LMS-USR , User Entity , How To