Symptom
Upon navigating to a User Record, when attempting to update the Required Date field of an assigned item, the field cannot be changed. The Required Date field needs to be updated by the administrator.
Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental.
Environment
SAP SuccessFactors Learning
Cause
The administrator role is missing one to two workflow. The workflow required to be added to the administrator role needs to be evaluated by your business needs and setup.
Resolution
- Click the menu SYSTEM ADMIN > SECURITY > ROLE MANAGEMENT
- Find the Admin Role from the Administrator that cannot change the Required Date and Edit
- Click WORKFLOW > Add one or more from list
- Expand the User Management group
- Find and select the workflow called "Edit Item Assigned to User (domain restricted by item)" and "Edit Item Assigned to User (domain restricted by user)"
- Click ADD
The administrator will now be able to update the Required Date field on the User Record.
Keywords
required date admin workflow role security unable edit modify update change item sf lms successfactors course , KBA , lmsadminui , LOD-SF-LMS-WOR , Roles & Workflows , LOD-SF-LMS-ITE , Items , Problem