Symptom
You search in Accounts with filter as Country or City, and you get inconsistent results.
Environment
SAP Cloud for Customer
Reproducing the Issue
- Go to the Customers work center.
- Go to the Accounts view.
- Select All Accounts.
- Select Show Filter.
- Select a country (e.g. China).
- Result shows also accounts with other countries (e.g. France, Germany etc.).
The same can be applied to the search by City.
Cause
The search of Accounts with filter Country or City considers all the addresses maintained for an account.
Resolution
- Go to the Customers work center.
- Go to the Accounts view.
- Go to the Adapt -> Edit Master Layout.
- Select Show Advance Filter for the query All Accounts.
- In the Advanced Filter -> Go to the Address section and select Add Fields.
- Select the checkbox for the field Main Address and choose the Apply button.
- It brings the Main Address Indicator as checkbox in the Advanced search.
- Select End Layout Changes.
- Select the query All Accounts.
- Go to the Advanced Filter.
- Input the Country (e.g. China).
- Tick the checkbox Main Address and then choose the Go button.
Keywords
advanced filter, account, city, country , KBA , LOD-CRM-ACC , Account , How To
Product
SAP Cloud for Customer add-ins all versions