SAP Knowledge Base Article - Public

2235010 - Error Message While Clearing Open Items in a G/L Account: Account XYZ: Balance in company currency is not zero

Symptom

While attempting to clear open items on a G/L Account, you select the open items you want to clear and ensure that the Balance in Company Currency is zero, however, upon executing the Clear action the system throws error message:

'Account XYZ: Balance in company currency is not zero.'

XYZ means the G/L Account ID.

Environment

SAP Business ByDesign

Reproducing the Issue

  1. Go to the General Ledger work center.
  2. Go to the General Ledger Accounts view.
  3. Search for the respective G/L Account XYZ and click Edit > Open Items on Selected Account. 
  4. Select at least two open items with the same Open Item Reference ID and ensure that calculated Balance in Company Currency is zero.
  5. Click Clear.
  6. Enter a Posting Date and click OK.

Error message is thrown:

'Account XYZ: Balance in company currency is not zero.'

Cause

Here the system considers all the open items with the same Open Item Reference ID irrespective of whether you've selected all these items and irrespective of the G/L Account.

In other words it means that if you've selected two open items totaling a Balance in Company Currency of zero but there's at least one more open item with same Open Item Reference ID in this same G/L Account or in another G/L Account the system will take this item into consideration and the calculated balance won't be zero.

This is the expected behavior of the system. Partial clearing of an Open Item Reference ID is not supported and, additionally, the Open Item Reference ID is only cleared when all assigned line items are selected and all items are balanced to zero.

Resolution

There are two possibilities for solving this issue: to remove the Open Item Reference ID from the open item(s) you won't select to clear or to select the open item(s) with same Open Item Reference ID during the clearing.

To remove the Open Item Reference ID, please follow the steps below:

  1. Go to the General Ledger work center.
  2. Go to the General Ledger Accounts view.
  3. Search for the respective G/L Account XYZ and click Edit > Open Items on Selected Account.
  4. Select the item(s) you want to remove the open item reference ID assignment.
  5. Click Remove Assignment.

 Remark: you might have more open items with same Open Item Reference ID in a G/L Account other than XYZ. You need to remove the assignment of these items as well.

To select the open item(s) with same Open Item Reference ID during the clearing please follow the steps below:

  1. Go to the General Ledger work center.
  2. Go to the General Ledger Accounts view.
  3. Search for the respective G/L Account XYZ and click Edit > Open Items on Selected Account.
  4. Select all the items with same Open Item Reference ID and ensure that Balance in Company Currency is zero.
  5. Click Clear, enter Posting Date and click OK.

If you've selected all the open items with the same reference and the Balance in Company Currency is zero you'll be able to post the clearing successfully.

See Also

2134225 - Error Message: Account 123 Balance in Company Currency is not Zero

This Knowledge Base Article covers the specific scenario where you have additional open items with same Open Item Reference ID in different G/L Accounts.

2134010 - Unable To Clear Open Items In GL Account

This Knowledge Base Article covers the scenario where the Clear button is grayed out.

Keywords

open items; balance in company currency; g/l account , KBA , SRD-FIN-GL , General Ledger , How To

Product

SAP Business ByDesign all versions