Symptom
When synchronizing E-Mails from Microsoft Outlook to C4C, always the Primary Contact of the Account is determined.
Environment
SAP Hybris Cloud for Customer
Reproducing the Issue
- Login to C4C system in Microsoft Outlook.
- Create an E-mail and sync it with C4C.
- The E-mail gets created in the E-Mail Activity view of the Activities work center.
- The E-Mail is assigned to the Primary Contact.
- If their is no Main Contact available in the Account, then the E-mail activity selects any available Contact of the Account as Primary Contact.
Cause
The behavior is scoping dependent.
Resolution
The automatic determination of Primary Contact/Arbitrary Contact can be turned off through fine-tuning the Involved Parties for E-mails. Under Party Role Assignment, you can disable determinations for Contact of Account. After this is turned off, Primary Contacts will no longer be automatically determined, and Arbitrary Contacts also will not be determined for the synchronized E-mail.
- Go to the Business Configuration work center.
- Go to the Implementation Projects view.
- Select the project and choose Open Activity List.
- Navigate to Fine-Tune.
- Show All Activities and Find Activities.
- Select Activities and choose Open.
- Select Maintain Involved Parties for E-Mails.
- Under Party Role Assignment -> Select Contact of Account.
- Select Maintain Determination.
- Uncheck the Active checkbox -> Select Ok.
- Save your changes.
The above configuration change means that the automatic determination of Contact will not happen for E-mails.
Keywords
E-mail, Outlook, Contact , KBA , LOD-CRM-ACT , Activities , How To