Symptom
The Value Help for Contacts doesn't provide creation possibility for Contacts.
Reproducing the Issue
- Go to the Sales work center.
- Go to the Opportunities view.
- Open any opportunity.
- Go to the Contacts tab.
- Select the Add button and select a role.
- Select Value Help of the Name field.
- In the Value Help you found that the desired contact is not available (because it was not created in the system).
- In this situation there should be an option of creating the Contact directly from the Value Help screen (may be by adding a button).
In current scenario, user have to close the Value Help -> Create a new Contact -> Then come back on the value help to add the contact.
Cause
This is the designed behavior of the SAP Cloud for Cutsomer.
In case you want to add a contact that does not already exist you don't have to add it first and then select in the value help of opportunity.
Instead in the opportunity UI, there is an action in the Gear icon (adjacent to the Add button) called as New. You can create a New contact here that after creation it shall get assigned to this opportunity automatically.
Resolution
- Go to the Sales work center.
- Go to the Opportunities view.
- Open any opportunity.
- Go to the Contacts tab.
- Select the Add button and select a role.
- Select Value Help of the Name field.
- In the Value Help you found that the desired contact is not available (because it was not created in the system).
- Close the Value Help screen.
- Now in the Opportunity UI, you can find a gear icon (adjacent to the Add button) called as New. You can create a New Contact here that after creation it shall get assigned to this opportunity automatically.
Keywords
KBA , LOD-CRM , Cloud for Customer , How To