Symptom
When trying to create a job requisition, the error message: "Error: Unable to process your request. Please contact your configuration team for assistance" appears:
Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental.
Environment
SAP SuccessFactors Recruiting Management
Reproducing the Issue
- Go to Recruiting
- Click on Create new job requisition
- Select the creation method
- Fill the initial mandatory informaiton before creating a new job requisition
RESULT: The error message appears and the job requisition is not created
Cause
- CAUSE 1:
This issue is caued by a missing permission in Role-Based-Permissions: Creating any forms in the BizX application requires the permission in Role-Based-Permissions to "User Login" (even if no-one will login with this username to the instance).
- CAUSE 2:
There is an OnInit Business Rule that is supposed to fill an operator field. This rule is not pulling any values and is setting the operator field to null, and the field is required, which means it can't be null.
- CAUSE 3:
The reason for this error is a corrupted index.
- Cause 4:
User is not an operator or approver on the requisition.
Resolution
See below the resolution for each Cause above listed:
- CAUSE 1:
Please find the relevant Permission Role in Admin Center > Manage Permission Role and grant the following permission to the role:
General User Permission > User Login:
After saving changes, users assigned to the Permission Role will be able to create requisitions.
- CAUSE 2:
Review the behavior of the rule. Confirm if all the fields are correct.
- CAUSE 3:
If the causes 1 and 2 don't resolve the issue, it is most likely that this is the cause of the issue. To resolve this, it requires a re-index. Please, raise a ticket to Product Support.
- Cause 4:
The user must be added as an operator, a member of a recruiting group or become an approver of the job requisition.
Keywords
RBP, Permission, Corrupted index, Job Requisition, Recruiting, unable, RCM , KBA , LOD-SF-RCM-ADM , Admin Center, RBP, Permissions and Settings , Problem