Symptom
No server location is available when attempting to import/upload a content in Learning.
Environment
SAP SuccessFactors Learning
Reproducing the Issue
- Access the Learning admin side >
- Content > Import Content >
- Select an action and click "Next" >
- Select the file to be uploaded to the content server >
- Note that the "Server Location" option is not available.
Cause
- The Learning admin does not have the correct permissions to access the deployment location.
- The deployment location has been deactivated or deleted.
Resolution
Ensure the Learning admin has the necessary permissions:
- Access the Learning admin side >
- System Administration > Security > Role Management >
- Search for the role that the Learning admin belongs to >
- "Permissions" tab >
- Select the "Expand All" option and search for the "Access Deploy Content To Server" permission >
- If it is not there, then add it by searching the above permission through the "add one or more from list" option >
- If it is there, check if there is a restriction under the "Function Restr." or "Entity Restr." tabs.
Check if the deployment location is active:
- Access the Learning admin side >
- System Administration > Configuration > Content Deployment Locations >
- Search for the deployment location.
See Also
Keywords
lms, learning, permission, access, add, view, content, server, location, deployment, feature, functionality, sftp, kal, kac , KBA , LOD-SF-LMS-WOR , Roles & Workflows , LOD-SF-LMS , Learning Management System , LOD-SF-LMS-CNT , Content , Problem
Product
SuccessFactors HCM Core 1508