SAP Knowledge Base Article - Public

2239407 - Report on Operator's Email Address not working - Recruiting Management

Symptom

When running an Ad Hoc Report and setting as columns Operator's Email Addresses, the report do not return the emails as expected.

Environment

  • SAP SuccessFactors Recruiting Management
  • SAP SuccessFactors Workforce Analytics

Cause

As of now, SuccessFactors do not support displaying the email fields of operators if the field is configured as derived. In "Derived" type fields, the values are automatically assembled based on the values present in the corresponding field on active and inactive users in the BizX user database.

Resolution

In case you need to report on Operator's Email Address (Recruiter, Hiring Manager, Originator, Sourcer, etc), the workaround is to create custom text fields which would have to be manually filled in Job Requisitions or Applications.

Currently the system only support reporting on:

  • Operator First Name
  • Operator Last Name
  • Operator User Sys ID

 It's also possible to create a Cross Domain or Multi Domain report in order to select another schema to obtain the user's email address. Please reach out to your implementation partner or SAP Professional Services in order to build the report accordingly.

Keywords

operator, email, job, requisition, hiring, manager, recruiter, coordinator, sourcer, report, adhoc. , KBA , LOD-SF-RCM , Recruiting Management , LOD-SF-RCM-REP , Reporting & Analytics, Data Imports & Exports , Problem

Product

SAP SuccessFactors Recruiting all versions