Symptom
While forwarding a job requisition for approval to an approver, there is an option for a recruiter/approver to comment in the "Comment Box". The comment box does not appear, as below:
Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental.
Environment
SAP SuccessFactors Recruiting Management
Cause
There are few settings in the admin tools which causes the comment box to disappear:
- [[DOC_COMMENT]] token should always be available in the “Document Routing Notification”.
- The option for “Disable Ask for Comment Routing” should be unchecked in Admin Center > Form Templates Settings > Respective Template
- The box will also not appear if the user is the same in both steps. In this case, the notification will not be sent either.
Resolution
[[DOC_COMMENT]] token should always be available in the “Document Routing Notification”.
Note: The e-mail option for "Document Routing Notification" needs to be enabled. If it is not enabled in the environment, the comment box won't appear even if the token is added to template.
The option for “Disable Ask for Comment Routing” should be unchecked in Admin tools > Form Templates settings.
Once these settings are correct the Comment Box appears in the approval section as shown below:
Note: It is not possible to make the Comments checkbox Required. It will show by default as Optional eachtime for Recruiters.
Keywords
Comment, box, [[DOC_COMMENT]], mandatory, required, checkbox, requisition, missing, route, approval , KBA , LOD-SF-RCM-EML , Recruiting Emails and Notifications , Problem