Symptom
When running a report on the Data Source Campaign Inbound Outbound some Campaigns have unassigned target groups.
Reproducing the Issue
- Go to Work Center Business Analytics, View Design Reports
- Find and open the report E-Mail Metrics: Numbers (or any other report on that data source)
- You see that some campaigns have to rows for target group, one with the actual target group and one or more # Not assigned
Cause
In the report, for a particular campaign each row corresponds to one execution step and the target group will only be shown for the first(main) execution step and not for the others. For others it will appear as not assigned.
Resolution
This behaviour cannot be changed. However, it is possible to only show the first execution step to avoid having unassigned rows in your report. In order to do so you will have to create a custom report.
- In the Design Reports view click New and either Report or Report as Copy
- In step 4 - Characteristic Properties select Fixed Value Selection for Target Group.
- Click on Set Fixed Value Selection
- Click on the little arrow symbol next to the Target Group field.
- Tick the But Exclude box and from the value help select # Not assigned (usually the last in the list)
- Click Ok
Finish creating/editing your report as usual. When you run this report only the first execution step will be shown for each campaign.
Keywords
KBA , SRD-FIN-ERM , Travel and Expense Management , How To