Symptom
- Report Exports display the wrong date in the header.
This is usually the previous or next date to what it should be. - For FTP exports, there is a difference of multiple hours between the time the file was received at the FTP server and the scheduled time in Report Distributor
Environment
SAP SuccessFactors HCM Suite
Reproducing the Issue
Log into the affected system
Navigate to:
- Home
- Analytics
- Analytics
- Report Distributor
- Select a bundle
- Schedule it to run at a time where it is known to show the wrong date
Cause
This issue is caused by local time settings.
i.e. The local per the computer from which the user schedules the bundle.
For the date exported header in the export, neither the analytics server time nor the BizX server time is used. This is the local time of the user exporting the report.
Resolution
To fix this, make sure that the user exporting the report is in the right time zone and the local time is set up correctly.
This is something for local IT to do as SAP has usually no access to local systems.
Keywords
Export, time, Report, Distributor, header, local, server, FTP, delay, hours, missing, wrong, mismatch, inconsistent , KBA , LOD-SF-ANA-ORD , Online Report Designer , How To