SAP Knowledge Base Article - Public

2242967 - When Creating a New Account, the Country Field is not Always Mandatory

Symptom

When creating a new account, the Country field is mandatory when you initially open the quick create.

When removing the already pre-filled country in the field, the field is no longer seen to be a mandatory one, and you can save the account without maintaining a country.

However, if a city was to be entered along with the country, and then the country was to be removed, the account can no longer be saved as in this case the Country field will still be seen as a mandatory one.

Environment

SAP Cloud for Customer

Reproducing the Issue

  1. Go to the Customers work center.
  2. Choose the Accounts view.
  3. Click on New Account.
  4. The Country field is set to mandatory.
  5. Remove the pre-filled country.
  6. The field is now not set as mandatory.

Cause

  • The country is dynamically mandatory if a postal address exists (e.g if postal address attributes are maintained).
  • The Country field only becomes mandatory if any postal address attribute gets filled.

Resolution

This is the expected system behaviour.

If you want to prevent accounts, without a country being maintained, from being saved, you have to set the Country to mandatory by using the Key User Tool.

Keywords

Mandatory;Field;KUT;Account;Customer;Country;City;Save. , KBA , LOD-CRM-ACC , Account , How To

Product

SAP Cloud for Customer add-ins all versions