Symptom
The Service Order remains in In Process status though the line item in the related Service Confirmation are already Canceled.
You expect the status of the Service Order to be Completed.
Environment
SAP Business Bydesign
Reproducing the Issue
- Go to the Service Orders work center.
- Go to the Service Order Processing view.
- Search and opem the service order XYZ (XYZ represents the ID of the service order).
- Select the Edit button.
- Select the View All button.
- Go to the Services and Spare Parts tab.
- Line item XX has the following status (XX indicates the sequence number of the line item):
- Status: In Process
- Service Status: Released
- Delivery Status: Finished
- Invoice Status: Not Started
- Cancellation Status: Not Cancelled
- Line item YY has the following status (YY indicates the sequence number of the line item):
- Status: Completed
- Service Status: Not Relevant
- Delivery Status: In Process
- Invoice Status: Not Relevant
- Cancellation Status: Cancelled
- Go to the Document Flow.
- Open the service confirmation ABC (ABC indicates the ID of the service confirmation).
- Select the View All button.
- Go to the Services and Spare Parts tab.
- For Line XX and YY you see the following status:
- Status: Finished
- Invoicing Status: Not Relevant
- Cancellation Status: Cancelled
- For Line XX there is an Actual Duration maintained
- Go to the Customer Invoicing work center
- Go to the Invoice Requests view.
- Search for the invoice requests created for the service order XYZ.
- You can find the Invoice Request DEF in the To be Invoiced status whichh has the line item XX of the service order.
Yout expect the Service Order status to be Completed.
Cause
Regarding the invoice request, one of the line items is currently in "To be Invoiced" status. As a result, the service order's status remains as "In Process."
Resolution
Create a invoice for invoice request DEF and then cancel the new invoice, this will update the invoicing status in service order for line item XX and you will be able to set Reason for Rejection for the same item in the service order.
After setting Reason for Rejection for line item XX & saving the service order, it will get completed.
- Go to the Customer Invoicing work center.
- Go to the Invoice Requests view.
- Search and select the invoice request DEF (DEF represents the ID of the invoice request).
- The status of the invoice request is To be Invoiced.
- Select the Invoice Request and choose Invoice button.
- Release the Customer Invoice.
- Cancel the Customer Invoice created.
- This will update the status of the invoicing in the service order, and you can set the Reason for Rejection for the line item XX.
- Save the service order after setting the Reason for Rejection.
The status of the service order will now be Completed.
Keywords
Service order; In Process; Service Confirmation; Canceled; Line Item; Invoice Request; Reason for Rejection; Completed , KBA , AP-SVO , Service Order Processing , SRD-CRM-SEO , Service Orders , How To