SAP Knowledge Base Article - Public

2245451 - Error During Assemble and Download of a Solution From SDK

Symptom

You will receive the below errors when you try to Assemble and Download of a solution from SDK.

There are inconsistent items.
To solve the problem, use the Check All Items function and fix the errors as instructed in the corresponding error messages.

Environment

SAP Cloud for Customer

SAP Business ByDesign

SAP Cloud Application Studio

Reproducing the Issue

  1. Open the solution.
  2. Go to Implementation Manager.
  3. Select the Assemble and Download option.

During the object activation the Assemble and Download procedure fails with the inconsistent error.

You will not get any errors when you use the Check All Items option.

Cause

If the solution is huge then the Assemble and Download functionality will fail because of the time-out inconsistency check which runs during this action.

Resolution

You can enable the Assembly Split functionality which is a new functionality introduced from 1511 release to avoid the time out situations.

Steps for enabling this feature are:

  1. Login to Cloud Application Studio.
  2. Open the solution.
  3. Naviagate to Implementation Manager tab.
  4. Click on Enable Assembly Split.
  5. After few seconds you will be able to see different options
  • Download Copy : This will put, all the solution objects into a new solution name (proposed by system based on aliasing) and provide a zip file. When you upload it, a new solution name is picked.
  • Activate
  • Assemble
  • Download : This will put all objects into original namespace and provide a zip file.

Keywords

Unhandled Exception occurs during Assembly HTTP 500 error during Activation , KBA , dump or unhandled exception , http 500(internalservererror) , AP-RC-BDS-1O , ByDesign Studio OneOffs , How To

Product

SAP Business ByDesign all versions ; SAP Cloud for Customer add-ins all versions