Symptom
Upon accessing a quiz or survey, only the primary locale is available for the end user, and the other locales are missing from the user preference.
Environment
SAP SuccessFactors Learning
Reproducing the Issue
- As a Learning user, proceed to the Learning Plan >
- Find the corresponding Item which has the associated quiz >
- Launch the Quiz >
- The quiz is shown to the User the Primary Locale set in that quiz and not user's active locale/language.
or
- As a Learning user, proceed to the Learning Plan >
- Find the survey and launch it >
- The survey is shown to the User the Primary Locale set in that quiz and not user's active locale/language.
For example:
- The user has the active locale set to Spanish >
- Navigate to Learning Landing Page >
- Find the survey that is supposed to have its questions translated into Spanish >
- Launch the survey >
- The survey appears in English.
Cause
The locales within the quiz or survey are not published.
Resolution
For Quizzes:
- Access Learning Administration >
- Proceed to Content > Assessments >
- Search for the Quiz and select it >
- The landing page will show all locales that the quiz has translations for >
- Make sure that the locales required for this quiz are published.
In case the locale cannot be published, make sure that the questions inside locale specific quiz have been translated and published.
For Surveys:
- Acess the survey >
- Navigate to "Questions" tab >
- Click in Publish.
Note: Please remember to publish the entities once changes are made.
Note 2: To ensure the survey/quiz runs smoothly, please clear the browser's cache after launching it for the second time.
Keywords
active, locale, translation, language, question, choice, missing, unavailable, not, available, quiz, quizzes, survey, surveys, follow-up, assessment, exam, publish, changes , KBA , LOD-SF-LMS-ASB , Assessment Builder , LOD-SF-LMS , Learning Management System , LOD-SF-LMS-EVA , Surveys , Problem