Symptom
You are importing Business Roles using the Migration tool. After successfully completed the migration file, you noticed the Business Roles are not available in Business Roles view.
Reproducing the Issue
- Go to Application and User Management work center
- Select Business Roles view
- The Business Roles that you have imported are not available
Cause
The Migration of Business Roles works differently than other migration objects.
The migration actually is for Business Role Replication, this basically creates replication request and not actual business role.
So, after completed the migration the data uploaded goes to Workcenter Data Integration.
Resolution
Once migration is successful uploaded, you can see the data in view Business Role Replication under Work Center Data Integration.
From Business Role Replication view, you need to select the replication request created and select the button Schedule. This will finally create/update the Business Role with new data in your system.
Keywords
KBA , AP-RC-BCT , Business Config. Tools (SAP Business ByDesign , How To