Symptom
When trying to purge inactive users in Data Management, user is not deleted with message "Employee belongs to compensation/variable pay form(s) thus cannot be purged.
Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental.
Environment
- SAP SuccessFactors HXM Suite
- SAP SuccessFactors Compensation
- SAP SuccessFactors Variable Pay
Reproducing the Issue
Replication of this as follows:
- Navigate to "Data Retention Management" from Admin Center> Company Settings
- Select Create New Purge Request
- Select Purge Inactive User
- Add the user(s) which you would like to purge
- Define selections under "Exclude users that meet the following criteria"
- Define approver
- Schedule or Launch Immediately
- User is not purged with message as below:
Cause
When creating a purging rule, the system historically does not provide the option to include users with existing Compensation and/or Variable Forms created in the rule. This option is greyed out and automatically selected to exclude these users.
With recent changes with the purge, the option "User belongs to an Incomplete compensation or variable pay form" was greyed out initially whereas this is now available to enable/disable.
Resolution
It is necessary to first purge the existing Compensation and Variable Pay forms including these users in the system to be able to purge the users from the system.
Normally these users will belong to deleted forms and that is the reason why you are not able to find these forms.
Note
In some cases, forms are not easy to find in the system.
The main reason is forms have been deleted but deleting a form on the customer instance is a SOFT deletion, the worksheet still exists in the system as they can be restored, if the customer user the Data Retention tool, then they must clean up all the deleted worksheets first even before finding the user in the live worksheet.
So, in ALL cases when you find this issue, the first step in all purge processes is to make sure the customer purges all the deleted Compensation forms.
You will need to create a new rule from Admin Center> Company Settings> Data Retention> Create New Purge Request> Purge Compensation/Variable Pay data with the following characteristics:
We recommend purging only deleted forms. In case the user belongs to an active form you must REMOVE the user from the form AND remove the budget associated to this user as well.
You will need to know the template the user is included in, otherwise you will need to create a rule for every template on the system.
You will need to know who the owner of the form is where the employee is included (first manager, second manager or rollup manager).
Keywords
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