SAP Knowledge Base Article - Public

2248132 - Unable to Access Learning After Refresh Activity

Symptom

  • Unable to access Learning via BizX from User side after LMS refresh activity
  • SAML Validation Error occurs when accessing Learning after the LMS refresh activity:

Validation Error

You must correct the following error(s) before proceeding: Failed to authenticate the SAML response. If this keeps happening, please contact the administrator.

Environment

SAP SuccessFactors Learning (LMS)

Reproducing the Issue

  1. Login via BizX (integrated login)
  2. Go to Learning

Cause

Before a refresh activity, the BizX configuration file in the Target instance is incorrect even though integration appears working.

Resolution

  1. Correct the integration of BizX and LMS by updating the BizX configuration file in LMS Admin.
  • Go to Admin > System Admin > Configuration > System Configuration > Edit Bizx
  • Search for "successFactorsCompanyID=" and change it to successFactorsCompanyID=<target company ID>

Example: from successFactorsCompanyID=testProd to successFactorsCompanyID=testStage

  1. Search for "baseURL" settings and change it to baseURL=<Target URL>

Example: From baseURL=https://performancemanager4.successfactors.com to baseURL=https://hcm4preview.sapsf.com

  1. Search for "metadataProviders[IDP1].value=https://performancemanager4.successfactors.com/idp/samlmetadata?company=" and update the url to point target companyID

Example: metadataProviders[IDP1].value=<bizX target URL>/idp/samlmetadata?company=<target company ID>
NOTE: This IDP URL left-side configuration may be malformed but working; however will casue issues post-refresh if incorrect, review brackets & periods used in teh default setting.

  1. Apply Changes

Keywords

SF, Success Factors, LMS, learning, Post refresh, BizX integration, URL redirect, company ID, after refresh validation error, SAML , KBA , LOD-SF-LMS-INT , Integrations with BizX , Problem

Product

SAP SuccessFactors Learning all versions